Encore un bug disparu qui revient

Sur ce forum, toutes les questions relatives à l'utilisation du logiciel de généalogie Généatique peuvent être postées.

Modérateurs: predigny, LEFF, peyroutet47

Encore un bug disparu qui revient

Messagede assyril » Dim 11 Déc 2011 11:11

Bonjour

à l’équipe du CDIP,

Cela fait déjà plusieurs message, où je montre mon agacement face aux bugs de G2012 et je ne suis pas le seul.

Là je viens de découvrir qu'un bug critique est réapparu : on sauvegarde (via le menu fichier/sauvegarder de la fiche détaillée) une note lié à un évènement et si on ne rajoute pas un espace ou un "chariot return" à la fin de cette note alors cette dernière est purement effacer quand on revient sur l'évènement.

çà + la fenêtre des illustrations qui est raccourci + la non modification de date de changement + la sélection des champs non visible dans les liste sélectives + sûrement d'autre que j'oublie encore

Accompagné de votre silence sur le forum, rien dans la rubrique "suggestions pour généatique", on ne sait pas ce que vous pensez de nos suggestion, sont-ils pris en compte? ...

Donc je vais repassé à G2011 car vu que la seule nouveauté vraiment intéressante est la recherche de lien de parenté et que ce n'est pas une fonctionnalité qui sert souvent

N.B.: je ne suis qu'un petit informaticien du dimanche, mais je n'arrive vraiment pas à comprendre comment de tels bugs puissent apparaître ou re-apparaître.

Cordialement
assyril
 
Messages: 474
Inscription: Lun 15 Oct 2007 18:53
Localisation: Les Yvelines

Re: Encore un bug disparu qui revient

Messagede predigny » Dim 11 Déc 2011 11:28

Pas de panique !
D'abord il faut avouer que sauvegarder une Note d'événement de cette façon, n'est pas très habituel, mais d'accord, ça doit marcher et ne pas effacer la note. Le problème c'est que je n'arrive pas à reproduire votre problème : le fichier est bien enregistré et la note n'est pas supprimée même si elle ne se termine pas par un espace ou un "return". Alors peut-être un élément me manque, ou que ce problème n'en est pas un...
pc sous Vista édition Familiale Premium ; G2007 à G2020 "Prestige"
predigny
 
Messages: 22862
Inscription: Jeu 6 Déc 2007 16:42

Re: Encore un bug disparu qui revient

Messagede assyril » Dim 11 Déc 2011 11:52

predigny a écrit:Pas de panique !
D'abord il faut avouer que sauvegarder une Note d'événement de cette façon, n'est pas très habituel, mais d'accord, ça doit marcher et ne pas effacer la note. Le problème c'est que je n'arrive pas à reproduire votre problème : le fichier est bien enregistré et la note n'est pas supprimée même si elle ne se termine pas par un espace ou un "return". Alors peut-être un élément me manque, ou que ce problème n'en est pas un...


Je préfère sauvegarder mes transcriptions d'actes en fichier rtf, cela fait une sécurité en plus de de la sauvegarde de la BDD.
C'est un bug que j'ai rencontré avec G2010 ou G2011 (je ne sais plus) puis résolu et là c'est réapparu. heureusement que je faisait attention et que je n'ai pas travaillé sur plusieurs fiches (car je suis partis pour çà, voir mon message "Question de methode - comment feriez-vous ")

Donc pour le mettre en évidence, dans l'évènement d'un de vos ailleux (voir sans note pour l'instant), saisissez quelques lignes puis vous sauvegarder puis vous cliquer (sans avoir recliquer dans la fenêtre de texte) sur un autre évènement. Quand vous revenez sur le premier évènement, est-il toujours là dans la zone de texte?
Si oui je ne comprends pas, car moi je n'ai plus rien et si je fait rechargé cette note depuis le fichier rtf sans saisir un caractère quelconque dans la zone de texte alors elle disparait à nouveau.

Je ne pense que ce soit un bug lié à mon environnement (Windows XP SP3) car là sous G2011, je n'ai aucun souci.

Je me suis un peu emporté mais cela m'a énervé car je ne suis pas toujours attentif dans mes saisis. Là par exemple je refait des transcriptions que je pensais avoir déjà faite mais pas de sauvegarde rtf ... donc rien de sûr.

Merci Pascal
Cordialement
assyril
 
Messages: 474
Inscription: Lun 15 Oct 2007 18:53
Localisation: Les Yvelines

Re: Encore un bug disparu qui revient

Messagede predigny » Dim 11 Déc 2011 12:33

assyril a écrit:... Quand vous revenez sur le premier évènement, est-il toujours là dans la zone de texte?....

Il y est toujours et les notes d'événement sont bien enregistrées, du moins sur Vista. Je vais remettre à jour mon vieux XP pour voir... et d'autres avis seraient les bien venus car il faut avouer que lors des tests préliminaires, je ne pense pas que ce test ait été beaucoup fait.
pc sous Vista édition Familiale Premium ; G2007 à G2020 "Prestige"
predigny
 
Messages: 22862
Inscription: Jeu 6 Déc 2007 16:42

Re: Encore un bug disparu qui revient

Messagede predigny » Dim 11 Déc 2011 12:47

Pas de problème sur mon XP du moins avec seulement deux ou trois essais....
________________________________________________________
pc sous Vista édition Familiale Premium ; G2007 à G2020 "Prestige"
predigny
 
Messages: 22862
Inscription: Jeu 6 Déc 2007 16:42

Re: Encore un bug disparu qui revient

Messagede phicome » Dim 11 Déc 2011 13:49

predigny a écrit:... et d'autres avis seraient les bien venus car il faut avouer que lors des tests préliminaires, je ne pense pas que ce test ait été beaucoup fait.


Je ne constate pas ce phénomène, s'il s'agit effectivement de ce que j'ai compris (sauvegarder avec le bouton menu de la note).
En revanche, curieusement, un "couper" (CTRL+X) coupe la note, mais pas son signalement dans l'évènement lequel fait mention d'une note qui n'existe pas (plus).
Ne tenir pour vrai que ce que l'on a soi même vérifié. (Montaigne)

Windows 10 familial (64 bits)
phicome
 
Messages: 2666
Inscription: Mer 21 Mai 2008 16:34
Localisation: 14

Re: Encore un bug disparu qui revient

Messagede assyril » Dim 11 Déc 2011 14:26

Je ne comprends pas. je vais allumer le portable qui est sous seven après pour voir.
La preuve que c'est du recuit : perds-transcription-des-actes-dans-les-notes-t8166.html
Phicome, votre remarque rejoint le fait que la modification d'une note ne modifie pas la date de dernière modification de la fiche et donc ne provoque pas la synchronisation sur clé USB ... très embêtant quand on circule sa généalogie via ce bias entre le portable et le fixe.


Cordialement
assyril
 
Messages: 474
Inscription: Lun 15 Oct 2007 18:53
Localisation: Les Yvelines

Re: Encore un bug disparu qui revient

Messagede predigny » Dim 11 Déc 2011 14:34

assyril a écrit:...Phicome, votre remarque rejoint le fait que la modification d'une note ne modifie pas la date de dernière modification de la fiche et donc ne provoque pas la synchronisation sur clé USB ...

Je ne pense pas que ce soit lié. Normalement quant la Note est vide, la structure de donnée qui a été crée pour accueillir la Note, est supprimée. Il se trouve que le Ctrl+X ne supprime pas cette structure vide. C'est une anomalie mais qui ne fait que ajouter quelques octets à la base de donnée. Le non enregistrement d'une petite modif. des notes sur la clé est plus ennuyeuse.
pc sous Vista édition Familiale Premium ; G2007 à G2020 "Prestige"
predigny
 
Messages: 22862
Inscription: Jeu 6 Déc 2007 16:42

Re: Encore un bug disparu qui revient

Messagede assyril » Dim 11 Déc 2011 16:05

Bon j'ai fait l'essai sous Seven, et c'est pareil mais pas systématique.
Et j'ai bien constaté le problème constaté par Phicome. Alors qu'il me semble que sous XP, cela ne me le fait pas.

Je peux en conclure que ce n'est peut-être pas évident à mettre en évidence. quoique vu que c'est un problème que j'ai depuis G2009, qui disparait pour ré-apparaître avec G2010 puis re disparait et réapparaît avec G2012. je ne semble pas avoir eu le problème avec G2011
Mais même si ce n'est pas évident, je ne comprends pas comment un bug puisse réapparaitre car une fois que le source est corrigé, les nouvelles versions sont bâtis sur ce nouveau source. Or les nouveautés de G2012 n'impacte pas le traitement de texte de Généatique à ce qu'il me semble donc normalement pas de modification dans le code de cette partie !

En voulant vérifier sur XP (et sous G2011) si le problème de Phicome arrive, j'ai eu un phénomène encore plus critique :

Sur l'évènement Baptême d'un ancêtre, je coupe la note avec ctrl+X,
puis je clique sur l'évènement Union (là la note est bien présente),
puis je clique à nouveau sur l'évènement baptême, là la punaise bleue est toujours présente alors qu'il n'y a plus de note.
Je retourne sur l'évènement union, et là je n'ai plus de note alors que je n'ai rien fait

Si après chaque saisi, manipulation de note, il faut vérifier que c'est bien toujours là, on est pas sortie de l'auberge
assyril
 
Messages: 474
Inscription: Lun 15 Oct 2007 18:53
Localisation: Les Yvelines

Re: Encore un bug disparu qui revient

Messagede geneliot » Lun 12 Déc 2011 13:31

J'ai également rencontrer un problème avec les notes que je n'ai pas pu reproduire :
Après avoir créer une catégorie "note confidentielle", j'ai fait le déplacement pour une dizaine de personne des notes normales vers la nouvelle catégorie "note confidentielle" par Ctrl+X , Ctrl+C. Pas de problème détecté sur le moment.
Je fais un export Gedcom en sélectionnant uniquement les notes normales.
Une vérification du Gedcom a fait apparaître une note confidentielle !!! Heureusement que j'avais fait une vérification mais cela a été un pur hasard de tomber dessus.

Cette note "parasite" était rattachée à une autre personne pour laquelle aucune note n'existait au préalable. Un symbole indiquait qu'une note était présente pour cette personne mais le contenu de cette note était vide. Cette note apparaissait toujours dans les exports Gedcom pour lesquels étaient exclues la catégorie "note confidentielle" en question.
Les différentes opérations de réparation de la base n'ayant rien changé, j'ai supprimé puis recréé la personne et le problème a disparu mais c'est pas pratique et surtout, la vérification d'un export Gedcom est loin d'être une opération facile. Il n'ai pas possible de vérifier systématiquement toutes les opérations sur les notes.

Ce problème se rajoute aux divers problèmes plus ou moins systématiques évoqués dans ce post.

Je conclurai les problèmes sur les notes sur un problème arrivé sur une version précédente : avant, je donnais les sources des informations dans les notes. Je me suis rendu compte récemment (version 2011) que certaines de ces notes avaient disparu. J'ai pensé à une fausse manipulation de ma part (je ne vois pas laquelle mais pourquoi pas). Je ne suis pas loin de penser qu'il y avait peut être déjà un problème avec les notes dans des versions précédentes. Difficile d'affirmer quoi que ce soit quand les problèmes ne sont pas détectés sur le moment.
geneliot
 
Messages: 16
Inscription: Mer 17 Nov 2010 12:47

Suivante

Retourner vers Forum Généatique 2020 - Logiciel de généalogie

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 10 invités