caractères spéciaux / ASCII

Forum pour les utilisateurs des anciennes versions de Généatique

caractères spéciaux / ASCII

Messagede Pierre Leboutte » Mer 15 Mar 2017 11:08

Bonjour,

quelqu’un saurait-il comment faire accepter par Généatique 2015 les caractères Ƶ et ƶ ?

Concernant les caractères ASCII, je ne trouve dans « l’aide » interne du logiciel et sur le forum de Généatique
que des indications concernant l’importation de fichiers (Gedcom etc.), mais rien sur la saisie de caractères spéciaux.

En Word par exemple, alt 437 donne Ƶ et alt 438 ƶ mais dans les champs de l’affichage principal d’une fiche,
ainsi que dans les champs « note », cela donne respectivement Á et Â.

Merci.
Pierre Leboutte
 
Messages: 4
Inscription: Mar 21 Avr 2015 18:03

Re: caractères spéciaux / ASCII

Messagede phicome » Mer 15 Mar 2017 12:16

Sous windows 10 :
Accessoires windows --> Table des caractères --> Sélectionner le caractère Unicode --> Copier --> Coller

Ƶ en majuscule Arial, par exemple.

Il n'y a pas de caractère ASCII (max 255)
Ne tenir pour vrai que ce que l'on a soi même vérifié. (Montaigne)

Windows 10 familial (64 bits)
phicome
 
Messages: 2666
Inscription: Mer 21 Mai 2008 16:34
Localisation: 14

Re: caractères spéciaux / ASCII

Messagede predigny » Mer 15 Mar 2017 12:43

Ca marchera dans les notes mais pas pour les Nom-prénom de la fiche simple. Je crains aussi pour le passage en gedcom.
pc sous Vista édition Familiale Premium ; G2007 à G2019 "Prestige"
predigny
 
Messages: 20624
Inscription: Jeu 6 Déc 2007 16:42

Re: caractères spéciaux / ASCII

Messagede Pierre Leboutte » Jeu 16 Mar 2017 19:34

Merci aux bonne volontés qui m'ont répondu.
Toutefois, mon problème n'est pas résolu.

Quand j'encode Alt 437 directement dans Généatique:
- dans un champ de l'affichage de base ("NOM" par exemple), j'obtiens comme indiqué dans ma question "Á"
- en "note" Arial 12, j'obtiens le "Ƶ"
Si je tente de copier/coller ce "Ƶ", depuis le champ note ou depuis Word, dans un champ de l'affichage de base,
j'obtiens un "?" désespérant.

Quand j'encode directement Alt 438 j'obtiens "Â" au lieu de "ƶ"
Quand je tente de copier/coller ce "ƶ" dans un champ de l'affichage principal, j'obtiens "z" non barré.

J'imagine qu'il me faudrait ajouter ces caractères à la liste de ceux que Généatique reconnaît... mais
comment ?

NB Il semble que le mot "Généatique" lui-même n'apparaisse ci-dessus que souligné en rouge, comme inconnu ?
Pierre Leboutte
 
Messages: 4
Inscription: Mar 21 Avr 2015 18:03

Re: caractères spéciaux / ASCII

Messagede predigny » Jeu 16 Mar 2017 20:06

Pierre Leboutte a écrit:...J'imagine qu'il me faudrait ajouter ces caractères à la liste de ceux que Généatique reconnaît... mais
comment ?
NB Il semble que le mot "Généatique" lui-même n'apparaisse ci-dessus que souligné en rouge, comme inconnu ?

On n'a pas accès aux polices utilisées par Généatique. Peut-être en bidouillant des polices système, mais avouez que le Z barré n'est pas fréquent et même pour des noms étrangers, il est admis de les "européaniser" car autrement on risque d'avoir de nombreux problèmes.
généatique est considéré comme mot inconnu de la langue française mais si vous mettez une majuscule ça devient un nom propre et vous pouvez l'ajouter au dictionnaire ; il vaut mieux ne pas ajouter généatique au dictionnaire car ce n'est pas un nom commun.
pc sous Vista édition Familiale Premium ; G2007 à G2019 "Prestige"
predigny
 
Messages: 20624
Inscription: Jeu 6 Déc 2007 16:42


Retourner vers Généatique 97, 2000, MX, 2004 à 2018

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités